DNS Service Degradation

Incident Report for SiteHost

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 11:02 NZDT

Monitoring

We have implemented some mitigations and the DNS service appears to now be stable.

If you are experiencing ongoing issues with SiteHost DNS resolution please get in touch to let us know.
Posted Jan 23, 2026 - 10:04 NZDT

Investigating

We are aware of ongoing issues with our DNS services due to denial of service attack. We are working to mitigate the issues.

This service degradation may result in intermittent issues resolving services that are using SiteHost DNS servers on or outside of our network.
Posted Jan 23, 2026 - 09:28 NZDT
This incident affected: DNS (Name Server 1, Name Server 2, Name Server 3).