.nz Domain Issues

Incident Report for SiteHost

Monitoring

InternetNZ have implemented a fix and .nz functionality has been restored. We'll continue monitoring closely, but registrations, renewals and transfers should all be working correctly now.
Posted Sep 22, 2026 - 10:22 NZST

Identified

Our upstream supplier InternetNZ has identified an issue at their end impacting multiple registrars. We're in contact with them and are awaiting a resolution (https://status.internetnz.nz/incidents/0lpv5xvhd2wr)
Posted Sep 22, 2026 - 10:01 NZST

Update

We are continuing to investigate this issue.
Posted Sep 22, 2026 - 09:20 NZST

Investigating

We're investigating an issue affecting all .nz domains. Registrations, renewals and transfers are currently unavailable. We'll update this notice as soon as we know more.
Posted Sep 22, 2026 - 09:20 NZST
This incident affects: Domains.