Let's Encrypt Outage
Incident Report for SiteHost
Resolved
Let's Encrypt have updated the outage status to indicate that it has been resolved. If you're experiencing any further problems with issuing or renewing SSL certificates, please contact us.
Posted Jul 12, 2024 - 15:24 NZST
Monitoring
The Let's Encrypt API appears to have been responding normally for the past few hours. While we're still waiting on an official resolution from Let's Encrypt & Cloudflare, renewals and issuing SSL certificates should now be performing as usual. We'll continue to monitor the situation until an official resolution is reached.
Posted Jul 12, 2024 - 14:47 NZST
Update
Let's Encrypt have advised that the issue is still under investigation. We have implemented an interim solution that allows us to bypass the issue on a per-server basis as needed. If you have an urgent requirement for an SSL certificate, please get in contact with us at support@sitehost.co.nz.
Posted Jul 12, 2024 - 08:46 NZST
Update
The Let's Encrypt API is hosted with Cloudflare and there seems to be network connectivity issues between NZ and their origin servers. Let's Encrypt are currently working with Cloudflare to get this issue sorted. They have updated their status page regarding the incident here:

https://letsencrypt.status.io/pages/55957a99e800baa4470002da
Posted Jul 11, 2024 - 16:20 NZST
Identified
We're currently aware of an issue affecting connections to Let's Encrypt's API endpoint from our servers in the AKL01 and AKL02 regions. This means that customers in these regions might experience failures when trying to renew or issue SSL certificates using Let's Encrypt. The problem seems to be impacting all locations in New Zealand.

We're looking into possible alternative solutions while we wait for this to be fixed by our upstream providers.
Posted Jul 11, 2024 - 13:00 NZST
This incident affected: Windows Virtual Servers (NZ – AKL01, NZ – AKL02), Cloud Containers (NZ – AKL01, NZ – AKL02), Linux Virtual Servers (NZ – AKL01, NZ – AKL02), and IPv4 Network (NZ – AKL01, NZ – AKL02).