Emergency Maintenance: Mail
Incident Report for SiteHost
Resolved
The maintenance is complete and full service should now be restored.
Posted 5 months ago. Jun 01, 2019 - 01:59 NZST
Identified
An emergency maintenance is underway on our mail system at present. Mail services may be delayed during this period. We apologise for the short notice and inconvenience.
Posted 5 months ago. Jun 01, 2019 - 00:38 NZST
This incident affected: Mail (IMAP, POP3, Webmail).