Targeted DDoS

Incident Report for SiteHost

Update

Service in New Zealand remains stable, however we are still noticing impact due to the DDoS attack upstream internationally. We are still working with our upstream providers to implement mitigations. We have additional engineers working 24/7. If you need assistance, please drop us an e-mail and we will do our best: support@sitehost.co.nz
Posted May 26, 2026 - 04:16 NZST

Identified

Our upstream providers have implemented additional mitigation measures to help address the ongoing issue. While these changes have improved overall service stability, some legitimate traffic may be impacted as a result.

If you are experiencing issues with your websites, applications, or servers, please contact our support team. We can work directly with you to identify any affected traffic patterns and make any necessary adjustments to restore normal operation.

We appreciate your patience and will continue to provide updates as the situation evolves.
Posted May 25, 2026 - 22:18 NZST

Investigating

We are continuing to experience service disruption related to ongoing issues between Cloudflare and SiteHost. Our team is actively working with our upstream providers to mitigate the impact and restore normal service as quickly as possible.

For customers who use Cloudflare, we strongly encourage you to log a support ticket directly with Cloudflare and raise this issue with them. This will help bring the issue to Cloudflare’s attention and allow them to provide further technical details, which will assist us in working toward a faster resolution. You may also provide Cloudflare with our contact email address support@sitehost.nz so their team can reach out to us directly for coordination.

Additionally, if you encounter network issues to our servers, please provide us with your IP address and traceroute to and from the server to your local network and forward to support@sitehost.co.nz.

We apologise for the inconvenience and appreciate your patience while we continue working toward a resolution.
Posted May 25, 2026 - 19:59 NZST

Update

We have applied a mitigation and websites/services that are not routed through Cloudflare should now be stabilising. We are still seeing degraded performance for some websites and services behind Cloudflare on certain networks and are continuing to investigate. We will provide further updates as more information becomes available. If you are still facing issues, please contact us at support@sitehost.nz
Posted May 25, 2026 - 17:05 NZST

Update

We are still observing degraded performance across some services in all regions. We are actively working with our upstream providers to investigate and resolve the issue. We will continue to monitor the situation closely and provide further updates as more information becomes available.
Posted May 25, 2026 - 15:27 NZST

Identified

We have applied a mitigation on the network in Sydney to address the current issue and services should now be stabilising. If you continue to experience any issues with services or applications hosted with us, or if you are aware of any UDP traffic to or from your server, please contact our support team at support@sitehost.nz.
Posted May 25, 2026 - 14:40 NZST

Update

Services are currently operating normally for traffic routed within New Zealand. However, international traffic continues to experience degraded performance. Websites utilising CDNs or services hosted outside New Zealand may be intermittently affected, and external monitoring systems may incorrectly report affected services as unavailable. We continue to work with our upstream provider on mitigation efforts.
Posted May 25, 2026 - 13:48 NZST

Update

We are working with our upstream provider to adjust DDoS protection settings and optimise mitigation measures. During this time, some customers may experience intermittent interruptions or degraded performance. We will continue to monitor the situation and provide updates as progress is made.
Posted May 25, 2026 - 13:13 NZST

Update

We are continuing to investigate this issue.
Posted May 25, 2026 - 12:31 NZST

Investigating

We are currently experiencing a Distributed Denial of Service (DDoS) attack affecting parts of our infrastructure. Our team is actively investigating the situation and implementing mitigation measures to minimise any impact on services.

Some customers may experience intermittent connectivity issues, increased latency, or temporary service disruptions while mitigation efforts are underway.

We will continue to provide updates as more information becomes available.
Posted May 25, 2026 - 12:02 NZST
This incident affects: Mail (IMAP, POP3, Webmail), API, Control Panel, Website, Domains, DNS (Name Server 1, Name Server 2, Name Server 3), Windows Virtual Servers (NZ – AKL01, NZ – AKL02, NZ – AKL03, AU – SYD01), Dedicated Servers (NZ – AKL01, NZ – AKL02, NZ – AKL03, AU – SYD01), Cloud Containers (NZ – AKL01, NZ – AKL02, NZ – AKL03, US – CAL01, UK – LDN01, SG – SGP01, AU – SYD01, DE - FRA01), Linux Virtual Servers (NZ – AKL01, NZ – AKL02, NZ – AKL03, AU – SYD01, US - CAL01, DE - FRA01), IPv4 Network (NZ – AKL01, NZ – AKL02, NZ – AKL03, AU – SYD01), and IPv6 Network (NZ – AKL01, NZ – AKL02, NZ – AKL03, AU – SYD01).