Ticketing System - Delayed delivery

Incident Report for SiteHost

Resolved

We have identified and fixed the issue and the tickets are now being delivered normally.
Posted Sep 07, 2026 - 11:33 NZST

Investigating

We are currently experiencing delays in receiving support tickets.

Our team is aware and working to resolve this as quickly as possible. Please be assured that your existing services are unaffected, customer servers, websites and email are operating normally.

For urgent issues, please call us: 0800 484 537
Posted Sep 07, 2026 - 11:08 NZST