Bad Connections from Azure/Microsoft to Cloud Container servers
Incident Report for SiteHost
Resolved
We are marking this issue as resolved now. If you are still experiencing any issues don't hesitate to contact us at support@sitehost.co.nz
Posted Jan 25, 2023 - 17:45 NZDT
Update
We are still seeing bad connections from the Azure/Microsoft range, but have now implemented rate limits to mitigate their impact on Cloud Containers. All previously dropped prefixes are now allowed to send traffic again.

We will continue monitoring the situation, and remove the current rate limits on the Azure/Microsoft range once the activity has subsided.

Do not hesitate to reach out to our support team at support@sitehost.co.nz should you notice any issues.
Posted Jan 24, 2023 - 16:32 NZDT
Update
We continue to monitor the situation and are still seeing bad connections from Azure/Microsoft. We have now added the following prefixes to our list of dropped web requests:

4.224.0.0/13
20.0.0.0/11
20.112.0.0/12
20.184.0.0/15
20.188.0.0/14
20.210.0.0/15
20.212.0.0/15
20.241.0.0/16
20.36.0.0/15
20.62.0.0/15
20.64.0.0/12
40.64.0.0/13
168.61.0.0/16
168.62.0.0/15
207.46.0.0/16

As usual, please get in touch with our support team at support@sitehost.co.nz should you notice any adverse impact on your Cloud Container servers.
Posted Jan 17, 2023 - 17:36 NZDT
Monitoring
We noticed an influx of bad connections from a list of IP prefixes from Azure/Microsoft to Cloud Container servers. We closely monitored it throughout the day and decided that the best course of action would be to drop web requests (TCP port 80 and 443) from the below list of prefixes:

13.64.0.0/11
13.96.0.0/13
13.104.0.0/14
23.96.0.0/13
40.74.0.0/15
40.76.0.0/14
40.80.0.0/12
40.96.0.0/12
40.112.0.0/13
40.120.0.0/14
40.124.0.0/16
40.125.0.0/17
52.145.0.0/16
52.146.0.0/15
52.148.0.0/14
52.152.0.0/13
52.160.0.0/11
104.40.0.0/13
104.208.0.0/13
157.54.0.0/15
157.56.0.0/14
157.60.0.0/16

Please get in touch with our support team at support@sitehost.co.nz if you notice any issues with connectivity from Azure/Microsoft to websites hosted on Cloud Containers servers.
Posted Jan 16, 2023 - 15:58 NZDT
This incident affected: Cloud Containers (NZ – AKL01, NZ – AKL02).