Shared Mail Service.
Incident Report for SiteHost
Resolved
The shared mail server has continued to operate normally and we are now marking this issue as resolved. If you are still experiencing issues please contact us at support@sitehost.nz.
Posted 16 days ago. Sep 02, 2019 - 15:13 NZST
Monitoring
This issue should be resolved, we're monitoring our Shared Mail Service closely if you notice any issues please contact support@sitehost.nz
Posted 16 days ago. Sep 02, 2019 - 14:39 NZST
Investigating
We are currently investigating an issue affecting our Shared Mail Service. Some email delays might be experienced.
Posted 16 days ago. Sep 02, 2019 - 11:51 NZST