Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 11, 2025 - 02:46 NZST
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 11, 2025 - 02:45 NZST
Scheduled
During this window, we are performing maintenance on a number of our internal services to help future proof our services by improving their security, reliability and performance.
There will be a short period in which the below websites will be unavailable. - webmail.sitehost.co.nz
We thank you for your understanding.
Posted Apr 11, 2025 - 02:45 NZST
This scheduled maintenance affected: Mail (Webmail).