Cloudflare Global Network experiencing issues

Incident Report for SiteHost

Resolved

Cloudflare have indicated that their services are considered stable. For further information, please see the Cloudflare status page for the event: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 19, 2025 - 08:31 NZDT

Monitoring

We have observed the fix that has been rolled out by Cloudflare is propagating. We are actively monitoring the situation. If you are still experiencing any issues please reach out to us on support@sitehost.co.nz
Posted Nov 19, 2025 - 03:46 NZDT

Identified

We are aware of an issue with Cloudflare. They are investigating issues with their services and/or network. More details on this can be found here: https://www.cloudflarestatus.com/
Posted Nov 19, 2025 - 01:52 NZDT