LetsEncrypt temporary outage

Incident Report for SiteHost

Resolved

All of our services appear to be operating correctly, LetsEncrypt is currently monitoring the status of their API.
Posted Jul 22, 2025 - 17:55 NZST

Monitoring

LetsEncrypt has implemented a fix which means certificate renewals should start working again. Keep in mind that they are experiencing higher than average traffic volumes so there may still be some delays in certificate renewal/issuing.
Posted Jul 22, 2025 - 15:13 NZST

Identified

We have become aware of an issue affecting automated SSL renewal/issuance on Cloud Containers and Servers that are using LetsEncrypt. They are currently dealing with the incident and we will be monitoring the status and keeping you posted as the situation develops.
Posted Jul 22, 2025 - 10:23 NZST
This incident affected: Dedicated Servers (NZ – AKL01, NZ – AKL02, NZ – AKL03, AU – SYD01), Cloud Containers (NZ – AKL01, NZ – AKL02, NZ – AKL03, US – CAL01, UK – LDN01, SG – SGP01, AU – SYD01, DE - FRA01), and Linux Virtual Servers (NZ – AKL01, NZ – AKL02, NZ – AKL03, AU – SYD01, US - CAL01, DE - FRA01).