Cloud Container SSL Certificate Issues
Incident Report for SiteHost
Postmortem

In the early hours of Thursday 19th of June a scheduled maintenance was performed on the Cloud Container platform in order to deploy updates and standardise our configurations across the fleet. For the majority of the affected containers this maintenance went smoothly.

However, a subset of the containers affected began to have issues with their SSL certificates. We are still determining the root cause of the multiple errors that led to this, but the end result was SSL certificates ceasing to work on these containers and errors being returned when these sites were accessed over HTTPS.

Once we identified the issue and the impacted containers, our team worked through the affected sites resolving the SSL certificate issues and bringing sites back up to a working state. We are continuing to monitor the containers for any future outages.

This incident has identified some areas in our testing and monitoring that we need to improve, and a review of this will be taking place over the next few days to reduce the likelihood and impact of outages such as this in the future.

We're sorry for the downtime that has resulted from this - we understand the impact that an incident like this can have on our customers and we will be doing everything we can to prevent this from happening again. If you would like to discuss anything further around this incident please do not hesitate to get in touch.

Posted 5 months ago. Jul 19, 2018 - 16:08 NZST

Resolved
We're not seeing any further related issues at this stage so we are marking this as resolved. A post-mortem of the incident will follow soon. If you are still experiencing SSL related issues on your Cloud Containers please let us know at support@sitehost.co.nz .
Posted 5 months ago. Jul 19, 2018 - 13:58 NZST
Monitoring
We have resolved most of the SSL certificate issues and are cleaning up any we may have missed along the way. We will continue to monitor the situation and fix any errors we encounter. If you are experiencing SSL errors on sites hosted on our Cloud Container product please get in touch at support@sitehost.co.nz .
Posted 5 months ago. Jul 19, 2018 - 12:21 NZST
Identified
We have identified the issues and our team is currently working through the affected containers and resolving the SSL certificate issues. We will update this incident as we progress.
Posted 5 months ago. Jul 19, 2018 - 10:16 NZST
Investigating
We're currently seeing a few SSL certificate issues that are affecting some of our customer sites. We are currently investigating and will post more updates when we know more.
Posted 5 months ago. Jul 19, 2018 - 09:02 NZST
This incident affected: Cloud Containers.