Shared Mail Service
Incident Report for SiteHost
Resolved
The shared mail server has continued to operate normally and we are now marking this issue as resolved. If you are still experiencing issues please contact us at support@sitehost.nz .
Posted 24 days ago. Jun 29, 2018 - 09:19 NZST
Monitoring
This issue should be resolved, we're monitoring our Shared Mail Service closely if you notice any issues please contact support@sitehost.nz
Posted 24 days ago. Jun 29, 2018 - 05:04 NZST
Investigating
We are currently investigating an issue affecting our Shared Mail Service.
Posted 24 days ago. Jun 29, 2018 - 03:34 NZST