Inbound calls not working
Incident Report for SiteHost
Resolved
This incident has been resolved.
Posted Dec 31, 2019 - 18:00 NZDT
Monitoring
Our upstream provider has fixed their issue and inbound calling is working again, we will continue monitoring the situation.
Posted Dec 31, 2019 - 16:57 NZDT
Investigating
Our upstream phone provider appears to be currently experiencing an outage, meaning customers cannot call. We are closely monitoring our email queue, so if you need to make contact simply drop an email to support@sitehost.co.nz with your contact details and someone will call you straight back.
Posted Dec 31, 2019 - 15:27 NZDT