Mail Delays
Incident Report for SiteHost
Resolved
This incident has been resolved.
Posted Mar 29, 2016 - 17:48 NZDT
Monitoring
Mail service should be accepting outgoing mail once again, we will continue to keep an eye on this as it resolves. If you are still experiencing mail delays feel free to get in touch with our support team.
Posted Mar 29, 2016 - 16:11 NZDT
Identified
There is currently a known issue with the reputation on one of our mail servers. Our engineers are working on resolving it at the moment, some outgoing mail may be delayed during this time.
Posted Mar 29, 2016 - 14:43 NZDT