Yahoo Xtra Mail Delays
Incident Report for SiteHost
Resolved
This incident has been resolved.
Posted Oct 16, 2015 - 16:25 NZDT
Investigating
Some customers may currently be unable to send email to Yahoo and Xtra addresses. We are investigating further and will post updates when we know more.
Posted Oct 16, 2015 - 10:12 NZDT