Mail Delays
Incident Report for SiteHost
Resolved
This incident has been resolved.
Posted Oct 13, 2015 - 13:39 NZDT
Monitoring
Outgoing mail should now be resolving again correctly, however existing mail already sent previously may take a little longer than normal to go out. If you still have trouble please feel free to contact our support team.
Posted Oct 13, 2015 - 10:07 NZDT
Investigating
There is currently a known issue with our mail servers. Our engineers are investigating this at the moment and we will post more information as it becomes available. Mail may be delayed during this time.
Posted Oct 13, 2015 - 09:23 NZDT