Yahoo Xtra Mail Delays
Incident Report for SiteHost
Resolved
All mail to Yahoo/Xtra hosted addresses should now sending again. If you have any further interruptions feel free to get in touch with our support team. support@sitehost.co.nz
Posted Aug 26, 2015 - 10:26 NZST
Monitoring
Mail now appears to be flowing again to Yahoo and Xtra hosted addresses. Some messages may take a few extra hours to send as the backlog clears.
Posted Aug 25, 2015 - 18:33 NZST
Investigating
Customers may currently be unable to send email to Yahoo Xtra (xtra.co.nz) addresses. We are investigating further and will post updates when we know more.
Posted Aug 20, 2015 - 12:15 NZST