Mail Server Outage
Incident Report for SiteHost
Resolved
The issue has now been resolved.
Posted Jan 25, 2017 - 15:53 NZDT
Monitoring
The mail server should now be up and running again and we are monitoring the server to ensure stability.
Posted Jan 25, 2017 - 15:34 NZDT
Investigating
We are currently experiencing an unplanned outage with our mail server. Our engineers are currently investigating the issue and we will post more information as it comes to hand.
Posted Jan 25, 2017 - 15:22 NZDT