API Outage
Incident Report for SiteHost
Resolved
Everything should be operating normally. If you encounter any further issues with the service, please contact support@sitehost.co.nz
Posted May 30, 2015 - 08:33 NZST
Investigating
Engineers are investigating
Posted May 30, 2015 - 08:06 NZST