Email Authentication Issues
Incident Report for SiteHost
Resolved
Access to our email servers should now be restored for all customers. We are continuing to monitor our servers closely in case of further issues.
Posted 15 days ago. Nov 26, 2018 - 14:04 NZDT
Investigating
We are aware that some customers are experiencing issues authenticating with our mail servers at present. Our engineers are investigating this at the moment and we will post updates here when we know more.
Posted 15 days ago. Nov 26, 2018 - 13:54 NZDT
This incident affected: Mail (IMAP, POP3).