Yahoo Xtra Mail Delays
Incident Report for SiteHost
Resolved
We believe this issue is now resolved but we are trying to contact Yahoo to prevent these issues in the future. If you do experience any problems please contact support.
Posted Jul 24, 2015 - 15:48 NZST
Monitoring
Yahoo appears to be accepting emails again but we are still waiting on updates from their support team
Posted Jul 24, 2015 - 18:04 NZST
Investigating
Customers may currently be unable to send email to Yahoo Xtra (xtra.co.nz) addresses. We will post further updates when we know more.
Posted Jul 22, 2015 - 14:12 NZST