Yahoo Xtra Mail Delays
Incident Report for SiteHost
Resolved
Mails are being relayed for xtra.co.nz since this morning
Posted Dec 08, 2015 - 12:38 NZDT
Investigating
Some customers may currently be unable to send email to Yahoo and Xtra addresses.
We are investigating further and will post updates when we know more.
Posted Dec 07, 2015 - 17:51 NZDT