Yahoo Xtra Mail Delays
Incident Report for SiteHost
Resolved
We believe this issue is now resolved we have contacted Yahoo and hope to prevent these issues in the future. If you do experience any further problems please contact support.
Posted Aug 03, 2015 - 10:26 NZST
Investigating
Customers may currently be unable to send email to Yahoo Xtra (xtra.co.nz) addresses. We are investigating further and will post updates when we know more.
Posted Jul 29, 2015 - 11:13 NZST