Yahoo Xtra Mail Issue
Incident Report for SiteHost
Resolved
The issue appears to be resolved and all the queued emails have been transferred to Yahoo's mail servers.
Posted May 22, 2015 - 10:00 NZST
Investigating
Customers may currently be unable to send email to Yahoo Xtra (xtra.co.nz) addresses. We are aware of the issue and are contacting Yahoo to try and resolve the issue. We will post further updates when we know more.
Posted May 21, 2015 - 14:13 NZST