Phone Lines Unavailable
Incident Report for SiteHost
Resolved
Our phones are now back up and you can reach us through all the usual methods!
Posted Jan 31, 2017 - 10:32 NZDT
Identified
Our phone system is unavailable due to an issue with one of our suppliers. We are working with our suppliers engineers to correct this issue, in the meantime for urgent requests please email support@sitehost.co.nz - this inbox is being monitored closely while this issue is ongoing.
Posted Jan 31, 2017 - 09:48 NZDT