North Shore Facility Problem
Incident Report for SiteHost
Resolved
We believe the problems at our North Shore facility are now resolved, and servers should be online. As always please contact support if you're having any problems.
Posted Jan 28, 2015 - 14:41 NZDT
Investigating
We are currently investigating a problem at our North Shore facility, we will post updates when we have more information.
Posted Jan 28, 2015 - 14:36 NZDT