Phone Lines Unavailable
Incident Report for SiteHost
Resolved
This incident has been resolved.
Posted Oct 26, 2015 - 17:11 NZDT
Identified
Our phone system is unavailable due to an issue with one of our suppliers. We are working with our suppliers engineers to correct this issue, in the meantime for urgent requests please email support@sitehost.co.nz - this inbox is being monitored closely while this issue is ongoing.
Posted Oct 26, 2015 - 16:43 NZDT